cmind-py can be installed in linux or Mac OS X.

Although installation is probably possible on Windows, the utility will be greatly reduced as many of the functions rely on tools from FSL, which only works in UNIX-like OSes. To use the software on Windows we recommend the use of a linux virtual machine with the appropriate dependencies installed: more info


A GIT repository containing the package source code is available at:

A zipped or tarred archive of the source code can be downloaded from the Downloads tab.

Alternatively, the source code may be checked out via git:

git clone

Installation from source

python install

Note: You may need to have root access to install the python packages. This can be achieved using sudo to obtain superuser priveledges as follows:

sudo python install

To specify an alternative installation location use the –prefix argument:

sudo python install --prefix=/usr/local

Specifying Pediatric Template Locations

A set of C-MIND pediatric study templates are available here: CMIND_Templates

cmind-py will search for these templates in the following locations, using the first location at which the template folder is found:

CMIND_TEMPLATE_DIR environment variable
~/cmind_templates    (where ~ is the user's home account)

Setting Up the Environment

cmind-py will attempt to automatically find FSL, ANTS and other software as needed at run time.

Run the following command to start cmind and print environment info:

python -c 'import cmind; cmind.print_environment_info()'

Install and/or set the suggested environment variables for any desired packages that are listed as missing.


All version numbers listed are those the software was developed with. Older versions are likely to work in some instances, but this has not been tested. The python pipelines make heavy use of routines from the fsl software library and the Advanced Normalization Tools.

  • Python 2.7+ (recommended) or 3.2+ (currently untested)
  • fsl 5.0+ (developed using fsl 5.0.2, 5.0.4 and 5.0.6).
  • ANTs 1.9.x+ (needs to be recent enough to have antsRegistration & antsApplyTransforms)

Most of the pipeline modules should also work with FSL 4.1, but will not.

The following Python modules are required

The minimum required version for each of these packages has not been determined. The software was developed using numpy 1.8.0, scipy 0.13.0, matplotlib 1.3.1, nibabel 1.3.0.

python modules needed for building the documentation

The DTI/HARDI preprocessing pipeline requires the following non-Python software

  • DTIPrep 1.1+ (tested with versions 1.1.6 and 1.2)
  • (optional): Slicer 4.2+ (tested with version 4.2.0) (only needed if denoising options are selected)

other optional non-Python dependencies

  • ImageMagick (tested usign 6.5.4 and 6.6.9)
  • AFNI (not currently used by default)

The following module, required by, is packaged with cmind-py